Para resolver problemas de inscripción con dispositivos, identifique si están parcialmente inscritos debido a pasos incompletos o problemas de red y aplique soluciones de resolución de problemas, como reinstalar el agente o inscribir dispositivos que aparecen fuera de línea, asegurándose de que se sincronicen.
¿Por qué este estado?
Durante el despliegue
Un dispositivo se considera parcialmente registrado cuando el proceso de registro en Factorial IT (o la implementación de MDM) no se ha completado por completo. Por lo tanto, el MDM aún no está activo en el dispositivo.
Esto puede suceder por varias razones:
- El usuario no completó todos los pasos de inscripción.
- La instalación del agente Fleet está incompleta (principalmente en macOS).
- El usuario no permaneció conectado el tiempo suficiente para completar la sincronización.
- El agente o perfil MDM fue desinstalado o bloqueado.
Cuando el dispositivo ya está inscrito
A continuación se muestran los diferentes escenarios posibles:
Agente desaparecido o inactivo
Este estado indica que el agente FleetDM instalado en el dispositivo ya no envía datos a FleetDM.
Posibles causas:
- El agente fue desinstalado o dañado
- El usuario o un script eliminó manualmente el agente.
- Un error de actualización o configuración del sistema corrompió la instalación.
- El agente ya no se está ejecutando
- El servicio
osqueryd(utilizado por FleetDM) se ha detenido. - El agente no puede iniciarse debido a problemas de permisos.
- Problemas de red o conectividad
- El dispositivo está en una red que bloquea el acceso al servidor FleetDM.
- El dispositivo ha estado fuera de línea durante demasiado tiempo, lo que impide que el agente se vuelva a conectar.
- Un proxy o firewall está bloqueando la comunicación entre el agente y el servidor FleetDM.
- El certificado o la configuración MDM ha expirado o está dañado
- Si su certificado APN (Apple Push Notification) ha expirado.
- Problema con FleetDM
Perfil MDM faltante (solo Mac)
Este estado indica que el perfil MDM falta o está inactivo en el dispositivo.
Posibles causas:
- El perfil fue eliminado por el usuario
- En macOS, un usuario administrador puede eliminar un perfil MDM desbloqueado.
- El perfil ha expirado o no es válido
- Un problema con el Servicio de notificaciones push de Apple (APNS) puede impedir que el dispositivo valide su perfil.
- Si el token APNS ha expirado o ha sido revocado, el perfil MDM puede volverse inválido.
- El dispositivo se eliminó accidentalmente de la administración de MDM
- Si la acción
turn off mdmse ejecutó desde FleetDM en el dispositivo.
Identificación de dispositivos parcialmente registrados
En su cabina de TI Factorial , puede identificar dispositivos parcialmente inscritos de dos maneras:
- El estado de inscripción del dispositivo proporciona información sobre posibles errores:
- Agente desaparecido
- Perfil faltante
-
Inscrito en otro MDM
- El dispositivo aparece como desconectado aunque un empleado lo esté utilizando activamente.
Solución de problemas
Aquí están las soluciones para cada situación:
- Perfil faltante (en macOS): solicite al empleado que siga los pasos detallados en esta guía, sección "Instalación en macOS" .
- Agente faltante (en macOS): En el panel del dispositivo, haga clic en el botón de estado del dispositivo para activar remotamente la instalación del agente. Si esto no funciona, pida al empleado que inicie sesión en su página de inscripción Factorial IT y haga clic en su dispositivo asignado. Luego, podrá descargar el agente de forma independiente.
- Inscrito en otro MDM : encuentra aquí toda la documentación necesaria sobre la migración de tu anterior MDM a Factorial IT: Migra tu dispositivo desde otro MDM
- Dispositivo sin conexión : Solicite al empleado que vuelva a inscribir su dispositivo. Puede automatizar esta acción en Configuración > Administración remota > Habilitar cancelación automática de la inscripción .
Una vez que el empleado complete estas acciones, el dispositivo debería aparecer como correctamente registrado en Factorial IT dentro de 30 minutos (el período de sincronización entre Fleet y Factorial IT).
Ahorre tiempo automatizando la reinscripción de empleados
En Configuración > MDM , habilite la cancelación automática de inscripción y seleccione la opción para reenviar automáticamente las invitaciones de MDM a los empleados cuyos dispositivos hayan sido purgados (es decir, dispositivos que hayan estado fuera de línea durante un período determinado).
