Per risolvere i problemi di registrazione dei dispositivi, identifica se sono registrati parzialmente a causa di passaggi incompleti o problemi di rete e applica soluzioni di risoluzione dei problemi come la reinstallazione dell'agente o la registrazione dei dispositivi che sembrano offline, assicurandoti che siano sincronizzati.
Perché questo stato?
Durante la distribuzione
Un dispositivo è considerato parzialmente registrato quando il processo di registrazione in Factorial IT (o implementazione MDM) non è stato completato. Di conseguenza, l'MDM non è ancora attivo sul dispositivo.
Ciò può accadere per diversi motivi:
- L'utente non ha completato tutti i passaggi della registrazione.
- L'installazione dell'agente Fleet è incompleta (principalmente su macOS).
- L'utente non è rimasto connesso abbastanza a lungo per completare la sincronizzazione.
- L'agente o il profilo MDM è stato disinstallato o bloccato.
Quando il dispositivo è già registrato
Ecco i diversi scenari possibili:
Agente mancante o inattivo
Questo stato indica che l'agente FleetDM installato sul dispositivo non invia più dati a FleetDM.
Possibili cause:
- L'agente è stato disinstallato o danneggiato
- L'utente o uno script hanno rimosso manualmente l'agente.
- Un errore di configurazione o di aggiornamento del sistema ha danneggiato l'installazione.
- L'agente non è più in esecuzione
- Il servizio
osqueryd(utilizzato da FleetDM) è stato arrestato. - L'agente non riesce ad avviarsi a causa di problemi di autorizzazione.
- Problemi di rete o di connettività
- Il dispositivo si trova su una rete che blocca l'accesso al server FleetDM.
- Il dispositivo è rimasto offline per troppo tempo, impedendo all'agente di riconnettersi.
- Un proxy o un firewall sta bloccando la comunicazione tra l'agente e il server FleetDM.
- Il certificato o la configurazione MDM sono scaduti o sono danneggiati
- Se il tuo certificato APN (Apple Push Notification) è scaduto.
- Problema FleetDM
Profilo MDM mancante (solo Mac)
Questo stato indica che il profilo MDM è mancante o inattivo sul dispositivo.
Possibili cause:
- Il profilo è stato rimosso dall'utente
- Su macOS, un utente amministratore può rimuovere un profilo MDM sbloccato.
- Il profilo è scaduto o non è valido
- Un problema con Apple Push Notification Service (APNS) potrebbe impedire al dispositivo di convalidare il proprio profilo.
- Se il token APNS è scaduto o è stato revocato, il profilo MDM potrebbe non essere più valido.
- Il dispositivo è stato rimosso accidentalmente dalla gestione MDM
- Se l'azione
turn off mdmè stata eseguita da FleetDM sul dispositivo.
Identificazione dei dispositivi parzialmente registrati
Nel cockpit IT Factorial puoi identificare i dispositivi parzialmente registrati in due modi:
- Lo stato di registrazione del dispositivo fornisce informazioni su potenziali errori:
- Agente scomparso
- Profilo mancante
-
Iscritto a un altro MDM
- Il dispositivo sembra offline anche se è attivamente utilizzato da un dipendente.
Risoluzione dei problemi
Ecco le soluzioni per ogni situazione:
- Profilo mancante (su macOS): chiedere al dipendente di seguire i passaggi dettagliati descritti in questa guida, sezione "Installazione su macOS" .
- Agente mancante (su macOS): nel pannello del dispositivo, fare clic sul pulsante di stato del dispositivo per avviare da remoto l'installazione dell'agente. Se questa operazione non funziona, chiedere al dipendente di accedere alla pagina di registrazione IT Factorial e di fare clic sul dispositivo assegnato. Potrà quindi scaricare l'agente in modo indipendente.
- Iscritto a un altro MDM : trova qui tutta la documentazione necessaria per la migrazione dal tuo precedente MDM a Factorial IT: Migra il tuo dispositivo da un altro MDM
- Dispositivo offline : chiedi al dipendente di registrare nuovamente il proprio dispositivo. Puoi automatizzare questa azione in Impostazioni > Gestione remota > Abilita disattivazione automatica della registrazione .
Una volta che il dipendente ha completato queste azioni, il dispositivo dovrebbe risultare correttamente registrato in Factorial IT entro 30 minuti (il periodo di sincronizzazione tra Fleet e Factorial IT).
Risparmia tempo automatizzando la reiscrizione dei dipendenti
In Impostazioni > MDM , abilita Annullamento automatico della registrazione e seleziona l'opzione per inviare automaticamente di nuovo gli inviti MDM ai dipendenti i cui dispositivi sono stati eliminati (ad esempio, dispositivi che sono stati offline per un certo periodo di tempo).
