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Resolver problemas de inscrição

Para resolver problemas de inscrição de dispositivos, identifique se eles estão parcialmente inscritos devido a etapas incompletas ou problemas de rede e aplique soluções de solução de problemas, como reinstalar o agente ou inscrever dispositivos que aparecem offline, garantindo que eles sejam sincronizados.


 

Por que esse status?

Durante o destacamento

Um dispositivo é considerado parcialmente cadastrado quando o processo de cadastro no Factorial IT (ou implantação de MDM) não foi totalmente concluído. Consequentemente, o MDM ainda não está ativo no dispositivo.

Isso pode acontecer por diversos motivos:

  • O usuário não concluiu todas as etapas de inscrição.
  • A instalação do agente Fleet está incompleta (principalmente no macOS).
  • O usuário não permaneceu conectado tempo suficiente para concluir a sincronização.
  • O agente ou perfil MDM foi desinstalado ou bloqueado.

Quando o dispositivo já estiver cadastrado

Aqui estão os diferentes cenários possíveis:

Agente ausente ou inativo

Este status indica que o agente FleetDM instalado no dispositivo não está mais enviando dados para o FleetDM.

Possíveis causas:

  • O agente foi desinstalado ou está corrompido.
  • O usuário ou um script removeu o agente manualmente.
  • Uma atualização do sistema ou um erro de configuração corrompeu a instalação.
  • O agente não está mais em execução.
  • O serviço osqueryd (usado pelo FleetDM) foi interrompido.
  • O agente não consegue iniciar devido a problemas de permissão.
  • Problemas de rede ou conectividade
  • O dispositivo está em uma rede que bloqueia o acesso ao servidor FleetDM.
  • O dispositivo ficou offline por muito tempo, impedindo que o agente se reconectasse.
  • Um proxy ou firewall está bloqueando a comunicação entre o agente e o servidor FleetDM.
  • O certificado ou a configuração MDM expirou ou está corrompida.
  • Se o seu certificado APN (Apple Push Notification) expirou.
  • Problema do FleetDM
 
 

Perfil MDM ausente (somente para Mac)

Esse status indica que o perfil MDM está ausente ou inativo no dispositivo.

Possíveis causas:

  • O perfil foi removido pelo usuário.
  • No macOS, um usuário administrador pode remover um perfil MDM desbloqueado.
  • O perfil expirou ou é inválido.
  • Um problema com o serviço de notificações push da Apple (APNS) pode estar impedindo o dispositivo de validar seu perfil.
  • Se o token APNS expirar ou for revogado, o perfil MDM poderá ficar inválido.
  • O dispositivo foi removido acidentalmente do gerenciamento MDM.
  • Se a ação turn off mdm foi executada a partir do FleetDM no dispositivo.
 
 

 

Identificação de dispositivos parcialmente cadastrados

No seu painel de controle Factorial IT, você pode identificar dispositivos parcialmente registrados de duas maneiras:

  1. O status de registro do dispositivo fornece informações sobre possíveis erros:
    • Agente desaparecido
    • Perfil ausente
    • Inscrito em outro MDM
       
  2. O dispositivo aparece offline, embora esteja sendo usado ativamente por um funcionário.

 

Solução de problemas

Aqui estão as soluções para cada situação:

  • Perfil ausente (no macOS): Peça ao funcionário para seguir os passos detalhados neste guia, na seção "Instalação no macOS" .
  • Agente ausente (no macOS): No painel do dispositivo, clique no botão de status do dispositivo para iniciar remotamente a instalação do agente. Se isso não funcionar, peça ao funcionário para acessar a página de inscrição do Factorial IT e clicar no dispositivo atribuído a ele. Ele poderá então baixar o agente por conta própria.
  • Inscrito em outro MDM : encontre aqui toda a documentação necessária para migrar do seu MDM anterior para Factorial IT: Migre seu dispositivo de outro MDM
  • Dispositivo offline : peça ao funcionário para registrar novamente o dispositivo. Você pode automatizar essa ação em Configurações > Gerenciamento remoto > Ativar cancelamento automático de registro .

Após o funcionário concluir essas ações, o dispositivo deverá aparecer como devidamente cadastrado no Factorial IT em até 30 minutos (o período de sincronização entre o Fleet e Factorial IT).

Economize tempo automatizando a reinscrição de funcionários.

Em Configurações > MDM , habilite o Cancelamento Automático de Inscrição e selecione a opção para reenviar automaticamente os convites MDM aos funcionários cujos dispositivos foram apagados (ou seja, dispositivos que ficaram offline por um determinado período).

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